Service outage

Incident Report for EBOX services

Monitoring

Please note that following an outage that occurred earlier, you may currently be experiencing technical issues with your connection. If that is the case, please unplug your modem and router from the power outlet, then plug them back in after a few seconds.
Thank you very much for your understanding.
Posted May 23, 2025 - 15:30 EDT

Investigating

Good morning ,
Please note that there is an outage with our FTTH services. We are currently working with our provider to fix the issue as soon as possible. No estimated time of resolution has been given at this time.
Thank you very much for your understanding.
Posted May 22, 2025 - 09:00 EDT
This incident affects: FTTH Quebec.