No service province of Québec.

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 14:43 EDT

Investigating

We are currently experiencing an issue with our Cable internet service in the province of Québec.
We have escalated the issue to our relevant carrier; however we do not currently have a time of resolution. We apologize for any inconvenience this may cause.
Posted Apr 16, 2026 - 09:00 EDT
This incident affected: Cable Quebec.