Important Notice – FTTH Installation Service Issue

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 11:39 EST

Monitoring

Good morning,
Attention EBOX customers:
Some customers who were installed yesterday on FTTH may currently be experiencing service issues.
If this applies to you, please contact us and have your account number ready. Our team will work with our provider to correct the service as quickly as possible.
We apologize for the inconvenience and thank you for your understanding.”
Posted Jan 20, 2026 - 08:13 EST
This incident affected: FTTH Quebec.