Cable outage Longueuil / Saint Lambert area

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 12:39 EST

Update

We are continuing to investigate this issue.
Posted Jan 13, 2026 - 12:37 EST

Investigating

A cable internet outage is currently affecting the Longueuil and Saint-Lambert areas.
Our teams are working to restore service as quickly as possible.

Thank you for your understanding.
Posted Jan 12, 2026 - 11:41 EST
This incident affected: Cable Quebec.