Network Notice – EBOX

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 12:39 EST

Monitoring

Hello,

Due to recent weather conditions and power outages affecting several regions of Quebec, some customers may experience degraded or interrupted telecommunication services.

We are working closely with our provider to resolve the situation as quickly as possible.
No estimated time of restoration is available at this moment.

Thank you for your understanding.
Posted Nov 11, 2025 - 10:09 EST
This incident affected: Cable Quebec.