TV service outage – service not functioning

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted May 08, 2026 - 07:16 EDT

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 07:14 EDT

Investigating

Please note that we are experiencing issues with our TV service. We are currently experiencing a high call volume. Consequently, the wait time to speak with a representative will be longer than anticipated.
Posted May 07, 2026 - 08:18 EDT
This incident affected: TV.