Customer Portal down

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 16:42 EST

Monitoring

Hello everyone,
We are currently experiencing an issue affecting the Customer Portal, preventing customers from logging in. Our teams are actively working to resolve the situation.

Thank you for your understanding.
Posted Dec 17, 2025 - 16:33 EST