Service outage

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Dec 07, 2025 - 15:29 EST

Monitoring

Hello.
We are currently experiencing higher than usual call volumes. The wait time to speak with a representative may be longer than normal. We are actively working to resolve the situation.
We apologize for the inconvenience and thank you for your understanding.
Thank you.
Posted Dec 06, 2025 - 09:55 EST
This incident affected: FTTH Quebec.