Fibre Internet Service Outage - Northeast Laval Area

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted May 10, 2026 - 18:57 EDT

Update

We are continuing to investigate this issue.
Posted May 10, 2026 - 18:56 EDT

Update

We are continuing to investigate this issue.
Posted May 10, 2026 - 10:00 EDT

Update

.
Posted May 10, 2026 - 09:45 EDT

Investigating

A Fibre Internet service outage is currently affecting the northeast area of Laval (postal codes H7A, H7B and surrounding areas).
A team is actively working to resolve the situation.
Posted May 10, 2026 - 09:41 EDT
This incident affected: FTTH Quebec and Cable Quebec.