Increased Call Volume in Ajax, Whitby, Pickering and Surrounding Areas

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 15:50 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 24, 2026 - 11:58 EDT

Monitoring

Network Status Update

We are currently experiencing a higher-than-normal call volume from customers located in Ajax, Whitby, Pickering, and surrounding areas in Ontario due to ongoing network maintenance.

As a result, some customers may experience temporary service interruptions or limitations, and wait times to speak with a representative may be longer than usual.

If your request is not urgent, we encourage you to visit our website for self-service options or to access your online account.

We apologize for the inconvenience and thank you for your understanding.
Posted Aug 24, 2026 - 08:47 EDT
This incident affected: Core Routing.