Service outage

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 09:00 EDT

Investigating

Hello,
Our telephony system is currently experiencing a technical issue affecting outbound calls. We are actively working to resolve the situation, but no estimated time of resolution has been established.
Thank you for your patience and understanding.
Posted Jun 08, 2025 - 12:00 EDT
This incident affected: Residential Phone.