Network Status Notice – Weather Conditions

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 08:39 EDT

Monitoring

Hello,
Due to current weather conditions and power outages in certain areas, some customers may experience service interruptions.

Our technical teams are actively working to restore service as quickly as possible.

We appreciate your patience and understanding while our teams make every effort to resolve the situation.
Posted Mar 12, 2026 - 10:36 EDT
This incident affected: FTTH Quebec, Cable Quebec, and DSL Quebec.