Technical Support – High Wait Times

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 15:16 EDT

Investigating

High wait times are currently being experienced when contacting Technical Support.
We apologize for any inconvenience this may cause.
Posted Aug 27, 2026 - 13:46 EDT
This incident affected: Call Center.