Issue Related to New Fibre Activations

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 20:55 EST

Investigating

An outage is currently affecting new Fibre customers with an activation date of January 19.
Our teams are actively working to resolve the issue.
If you are affected, please contact us by phone so we can restore your service.
Posted Jan 19, 2026 - 19:37 EST
This incident affected: FTTH Quebec.