Outages in Quebec and Ontario

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Jan 25, 2026 - 09:00 EST

Identified

Affected areas in Greater Toronto area, East York & North York are resolved. Montreal area is pending with localised outages being gradually resolved.
Posted Jan 24, 2026 - 18:41 EST

Investigating

Several areas in Quebec (mainly in the Greater Montreal area) and Ontario (mainly in the Greater Toronto area, East York & North York) are experiencing isolated outages due to low temperatures.
Depending on the equipment or technology installed at your residence, if the DSL / INTERNET / PON light on your device is blinking or off, you may be affected by the outage.

Our teams are working to restore service as quickly as possible.
Posted Jan 24, 2026 - 09:52 EST
This incident affected: FTTH Quebec, DSL Quebec, and DSL Ontario.