Service outage

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted May 31, 2025 - 18:24 EDT

Investigating

Hello,
Our internal tools are currently experiencing a technical issue, which is preventing us from accessing your account. We apologize for the inconvenience. A member of our team may need to call you back once the issue is resolved. Thank you for your understanding.
Posted May 31, 2025 - 12:15 EDT
This incident affected: Call Center.