Outage in progress.

Incident Report for EBOX services

Resolved

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 12:15 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 12:14 EDT

Monitoring

Hello,

Due to yesterday’s severe weather conditions, including strong winds that affected various areas and caused power outages, some customers may be experiencing service interruptions.

Our technical teams are actively working to restore services as quickly as possible.

We sincerely appreciate your patience and understanding while our teams make every effort to resolve the situation.
Posted Mar 18, 2026 - 08:53 EDT
This incident affected: FTTH Quebec and Cable Quebec.