Service outage

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted May 21, 2025 - 13:44 EDT

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 13:26 EDT

Update

Service has been restored for the majority of customers. If you are still experiencing issues, please reboot your modem and router. Thank you.
Posted May 21, 2025 - 11:44 EDT

Update

Services are gradually resuming in certain sectors
Posted May 21, 2025 - 10:30 EDT

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 09:55 EDT

Investigating

Please note that there is an outage affected multiple services
We are currently working with our provider to fix the issue as soon as possible. No estimated time of resolution has been given at this time. Thank you very much for your understanding.
Posted May 21, 2025 - 09:47 EDT
This incident affected: FTTH Quebec, Cable Quebec, TV, DSL Quebec, Call Center, Commercial Fiber, and Residential Phone.