Speed Degradation in Montreal

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 08:52 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 26, 2026 - 20:40 EDT

Identified

We are currently aware of an issue affecting some Fiber customers in the Montreal area, who may be experiencing slower than normal internet speeds.

The issue has been escalated to our carrier, and we are actively working with them toward a resolution. At this time, there is no estimated time for service restoration.

We apologize for the inconvenience and appreciate your patience while we investigate and resolve the issue.
Posted Aug 26, 2026 - 20:38 EDT
This incident affected: FTTH Quebec.