FTTH Internet Slow Speeds – Sherbrooke and Saint-Jean-sur-Richelieu Areas

Incident Report for EBOX services

Update

We are continuing to work on a fix for this issue.
Posted Oct 27, 2025 - 12:53 EDT

Identified

Hello
We are currently experiencing issues with our FTTH Internet services in the Sherbrooke (QC) and Saint-Jean-sur-Richelieu (QC) areas.
Customers may notice slower Internet speeds during evening hours, between 7:00 PM and 10:00 PM.

We have notified the affected provider about the situation, but at this time, we are unable to confirm when the issue will be resolved.

We apologize for any inconvenience this may cause and thank you for your patience.
Posted Oct 27, 2025 - 12:20 EDT
This incident affects: FTTH Quebec.