EBOX TV and Website Outage Notice

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 08:26 EST

Update

We are continuing to monitor for any further issues.
Posted Dec 11, 2025 - 08:26 EST

Monitoring

Hello,
We are currently experiencing an outage affecting the EBOX TV service as well as the ebox.ca website.
Our teams are already working to resolve the situation as quickly as possible.
We apologize for the inconvenience and thank you for your patience.
Posted Dec 11, 2025 - 07:33 EST
This incident affected: TV.