Service outage

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 13:21 EDT

Update

We are continuing to investigate this issue.
Posted Aug 06, 2025 - 13:21 EDT

Investigating

We are currently experiencing a high call volume. Consequently, the wait time to speak with a representative will be longer than anticipated. If your request is not of an urgent nature, you can visit our website for alternate methods of contact or to login to your account.
We apologize for the inconvenience and thank you for your understanding.
Thank you
Posted Aug 05, 2025 - 18:44 EDT
This incident affected: Call Center.