Phone Service Not working

Incident Report for EBOX services

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 08:09 EST

Update

We are currently experiencing high call volumes due to an outage affecting EBOX phone service. We apologize for the inconvenience. Please stay on the line, and an agent will be with you shortly.
Posted Feb 03, 2026 - 10:52 EST

Update

We are continuing to investigate this issue.
Posted Feb 03, 2026 - 10:36 EST

Investigating

We are currently investigating this issue.
Posted Feb 03, 2026 - 10:31 EST
This incident affected: Residential Phone.